Jump to content
Chribee

Discovery Media +: Playlist auf SD-Karte ITunes - wie bekomme ich die zum laufen

Recommended Posts

Chribee

Hallo,

 

ich habe mir nach einem Jahr nun endlich mal eine SD-Karte gekauft, um die Musik immer im Auto zu haben.

Ich habe die Ordner mit meiner Musik analog zur iTunes Ablage kopiert. Es werden auch Titel, Alben und Interpreten gezeigt sowie gespielt aber die Playlist bekomme ich nicht zum laufen.

 

Hier mal einen Auszug aus meiner Textdatei der Playlist:

 

#EXTM3U

#EXTINF:271,Seconds - Little Dragon

../Little Dragon/Ritual Union/11 Seconds.mp3

 

Dazu die Verzeichnisstruktur auf der SD Karte:

 

Pfad der Mp3 Datei:

Musik (= Name der SD-Karte)/Little Dragon/Ritual Union/11 Seconds.mp3

 

Pfad der M3U Datei:

Musik, also direkt im Stammverzeichnis der SD-Karte (keine weiteren Unterordner)

 

Was mache ich denn falsch? Ich habe mich schon im WWW belesen, wahrscheinlich schnalle ich es nicht mit der Verzeichnisstruktur.

Fehlt in der Textdatei jetzt noch der Name meiner SD Karte mit "Musik"?

 

Also so ?:

#EXTM3U

#EXTINF:271,Seconds - Little Dragon

..Musik/Little Dragon/Ritual Union/11 Seconds.mp3

 

 

Wäre für Eure Hilfe dankbar.

 

Frohe Ostern.

Chribee

Share this post


Link to post
miq
You do not have the required permissions to view the quote content in this post.

 

Hallo,

wenn das so abgelegt ist wie du es beschrieben hast,

stimmt der relative Pfad zu den MP3-Dateien nicht. Versuch es mal mit:

 

#EXTM3U

#EXTINF:271,Seconds - Little Dragon

Little Dragon/Ritual Union/11 Seconds.mp3

 

Idealerweise benutzt man immer relative Pfade in einer Playlist und legt die M3U direkt im Verzeichnis mit den MP3-Dateien (in deinem Fall Little Dragon/Ritual Union) ab. So lässt sich das komplette Verzeichnis mit Playlist kopieren.

 

Name der SD-Karte ist bei relativen Pfadangaben auch egal.

 

Grüße.

Share this post


Link to post
Chribee

Super Danke!

 

Jetzt geht!👍

 

Beste Grüsse

Chribee

Share this post


Link to post
stiptec

Hallo Chribee,

 

hier zum Thema Playlists auch noch ein paar Tipps von mir:

 

Ich exportiere die Playlists aus ITUNES mit der rechten Maustaste als m3u in einen lokalen Ordner. Die Pfade in der m3u verweisen natürlich auf den spezifischen Ordner auf dem PC, so den andere Geräte nicht verorten können. Ich lasse deshalb über den gesamten Ordner eine Stapelverarbeitung laufen mit dem Programm BTR Wizard (Freeware, einfach googeln) und ändere die Pfade auf einen Schlag in den Pfad der Musikanlage des jeweiligen Gerätes. Das funktioniert hervorragend.

 

Beispiel: D:\Users\Benutzername\Documents\iTunes\iTunes Media\Music\ wird ersetzt durch ..\

 

(Die Musik liegt bei mir auf der SD-Karte im Ordner Music)

 

Das geht für eine Vielzahl von Playlists in weniger als 1 Sekunde. Aktualisierte Playlists übertrage ich so einfach neu auf die Karte.

 

Vielleicht hilft dir das noch ein wenig weiter?

 

Gruß

 

Stiptec

Share this post


Link to post
Tiidabeljuu

Hallo zusammen

 

Ich bin ganz neu im Board und habe mich angemeldet, um Hilfe zu genau diesem Thema zu kriegen.

 

Ich habe beherzt sämtliche Ratschläge welche hier erteilt wurden eingehalten, bringe jedoch die Karte mit Playlisten nicht zum laufen. 

 

Ich vermute, dass es an den Voraussetzungen gemäss Bedienungsanleitungen liegt:

 

- Playlisten (nicht verkettet) nicht grösser als 20 kB und mit nicht mehr als 1000 Einträgen.

- Pro Ordnerebene max. 1000 Elemente (Elemente sind Ordner, Playlisten und Audiodateien).

- Pro Datenträger max. 30000 Audiodateien.

 

Ich habe gesamthaft  6510 Audiodateien, welche ich über Playlisten abspielen möchte. Den Export aller Songs habe ich aus iTunes direkt auf die SD-Karte mit dem Namen "California" ins Stammverzeichnis übertragen, was eventuell der 2. Voraussetzung widerspricht..

 

Ich kriege jedoch Playlisten (auch nicht kleiner als 20 kB) zum laufen.

 

Hier ein Auszug aus der Playliste:

 

#EXTM3U

#EXTINF:180,On Ira - Zaz

Zaz/Recto Verso/01 On Ira.m4a

 

Habt ihr mir eine Lösung? Vielen Dank im Voraus.

 

Tiidabeljuu

Share this post


Link to post
Tiidabeljuu
You do not have the required permissions to view the quote content in this post.

 

Hallo zusammen

 

ich habe noch einen Fehler bemerkt. Ich meinte natürlich:

 

Ich kriege jedoch Playlisten (auch kleiner als 20 kB) nicht zum laufen.

 

Mittlerweile habe ich auch mit nur 20 Titeln und einer kleinen Playliste getestet, trotzdem ohne Erfolg. 

 

Stimmt mit meinem Pfad Zaz/Recto Verso/01 On Ira.m4a etwas nicht?

 

Danke für eure Hilfe.

 

Tiidabeljuu

 

Share this post


Link to post
Hermann_D

Bei mir laufen auch Playlists mit 25 KB.

 

Allerdings habe ich in den Listen keine Slashes / sondern Backslashes \ drin, also

 

#EXTM3U

#EXTINF:180,On Ira - Zaz

\Zaz\Recto Verso\01 On Ira.m4a

 

ggf. den führenden Backshash nicht vergessen.

Share this post


Link to post
MaHo

ich habe hier interessiert mitgelesen aber ich bekomme meine Playlist nicht zum laufen. Vielleicht könnt Ihr mir auch auf die Sprünge helfen.

 

ich  ein Verzeichnis "music" eingerichtet und die Alben aus meiner iTunes Mediathek (Programm heißt ja jetzt Musik, benenne es aber weiterhin so) direkt dorthin kopiert. 

die Musik wird erkannt uns abgespielt, SD-Karte funktioniert also.

Für Playlists habe ich einen separaten Ordner "playlists" erstellt und die Playlist Datei dorthin kopiert

 

Ich hatte hierzu zum Test eine kleine Playlist in iTunes erstellt und auf  die SD Karte  kopiert. Anschließend  habe ich die Pfade angepaßt bzw. es zumindest versucht. HIer ein konkretes Beispiel. Versucht habe ich:

 

"Music/Schiller/Sonne/15 Ultramarin.mp3" - mit Slash und auch mit Backslash

"./Music/Schiller/Sonne/15 Ultramarin.mp3" - also mit führenden Slash/Backslash und 1 Punkt

"../Music/Schiller/Sonne/15 Ultramarin.mp3"- also mit führenden Slash/Backslash und 2 Punkten

 

das mp3-File (15 Ultramarin.mp3) ist in dem Ordner "Sonne" unter "Schiller" vorhanden und einzeln auch abspielbar.

 

Im Ergebnis erhalte ich immer den Fehlerhinweis "keine abspielbare Datei"

 

Meine Logik wäre, ich muss einen relativen Pfad erstellen, der Playlist sagen, dass sie 1 Ordner zurückspringen muss und von dort im Verzeichnis "music" den Pfad zur Datei "15 ultramarin.mp3" suchen soll. Wo liegt hier mein Denkfehler?

Share this post


Link to post
Hermann_D
Posted (edited)

Versuchs mal mit

 

\Music\Schiller\Sonne\15 Ultramarin.mp3

 

mit Backslash am Anfang als absoluten Pfad.

Edited by Hermann_D

Share this post


Link to post
MaHo
You do not have the required permissions to view the quote content in this post.

leider das gleiche Ergebnis :|

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Facts and figures

    75 members have viewed this topic:
    Kaleu  mamax0207  MatthiasR  MaHo  Tiidabeljuu  Cali_Ben  piitsch  Arkon  Emmental  tonitest  Alcali  tomwar  Forthradler  Hermann_D  Almroad  crumpi  f.schulz  Häuptling  ttbs  Bksocke  dufu75  Skep  VanDamme  qp_ch  stonie  simisch  nobsi  T3-4-5  Eff  peku  Silky276  pipophil  alder  Schattenpark3r  fettweg  CALIRADI  Q-Biker  21109  karmantx  IPSC_Tolot  Oldenbuerger  chruesi  recamp  SambaOnTheBeach  mellande  bayerflyer  motorpsycho  Bulliolli  schwedenfan  Igel  nick0297jan  tkuehler  calimerlin  habu01  Currywurst  Hasenjaeger  Vespas50  Vino  Driver  luki-1  Calidad  Mario70  Ferdo  kraxlhuaba  newbie-t6  transalpia  Litespeed-21  LuBus  numen  calitaxi  mafi65  Cali2017  bayer1639  fuetti  Jang69 
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.